[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt can't get capablities



On 07/03/2012 09:12 AM, Li Zhang wrote:
On 07/02/2012 05:53 PM, Christophe Fergeau wrote:
Hey,

On Mon, Jul 02, 2012 at 05:47:08PM +0800, Li Zhang wrote:
2003-01-02 01:22:00.135+0000: 12207: error :
qemuCapsComputeCmdFlags:1218 : unsupported configuration: this qemu
binary requires libvirt to be compiled with yajl

Your first problem is here, you need to have yajl-devel installed before
building libvirt.
Hi,

I tried on my x86 machine to installed all these packages.

[root mcd ~]# rpm -qa yajl
yajl-1.0.12-1.fc16.x86_64
[root mcd ~]# rpm -qa yajl-devel
yajl-devel-1.0.12-1.fc16.x86_64

[root mcd ~]# lsmod |grep kvm
kvm_intel             119203  0
kvm                   347474  1 kvm_intel

[root mcd ~]# virsh capabilities
<capabilities>

   <host>
     <uuid>d4ff0166-0f8b-e111-ab17-78a277034000</uuid>
     <cpu>
       <arch>x86_64</arch>
       <model>Nehalem</model>
       <vendor>Intel</vendor>
       <topology sockets='1' cores='4' threads='1'/>
       <feature name='rdtscp'/>
       <feature name='avx'/>
       <feature name='osxsave'/>
       <feature name='xsave'/>
       <feature name='tsc-deadline'/>
       <feature name='x2apic'/>
       <feature name='pdcm'/>
       <feature name='xtpr'/>
       <feature name='tm2'/>
       <feature name='est'/>
       <feature name='smx'/>
       <feature name='vmx'/>
       <feature name='ds_cpl'/>
       <feature name='monitor'/>
       <feature name='dtes64'/>
       <feature name='pclmuldq'/>
       <feature name='pbe'/>
       <feature name='tm'/>
       <feature name='ht'/>
       <feature name='ss'/>
       <feature name='acpi'/>
       <feature name='ds'/>
       <feature name='vme'/>
     </cpu>
     <power_management>
       <suspend_mem/>
       <suspend_disk/>
       <suspend_hybrid/>
     </power_management>
     <migration_features>
       <live/>
       <uri_transports>
         <uri_transport>tcp</uri_transport>
       </uri_transports>
     </migration_features>
     <secmodel>
       <model>selinux</model>
       <doi>0</doi>
     </secmodel>
   </host>

</capabilities>


It may be caused some packages which are required.
I am not quite sure about that.

I reinstall all the packages required.
As the following:

Libtool (glibtoolize toolize)
Gnutls
Gnutls-devel
Gnutls-c++
libgnutls
pkgconfig(libtasn1)
libgpg-error-devel
libgcrypt-devel
libtasn1-devel
device-mapper-devel/libdevmapper >= 1.0.0
Python-devel
Gettext-devel (autopoint)
Htmldoc
Libxml2-devel
xhtml1-dtds

And remove libvirt source code, then git clone latest source code.
Then I compile it and install libvirt.

It seems that it works.


Hope that helps,

Christophe




--
Best Regards
Li

IBM LTC, China System&Technology Lab, Beijing



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]