[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] trying to build 0.9.13 on F17: cannot find -lcrypto



On Thu, Jul 12, 2012 at 02:20:11PM +0200, Christophe Fergeau wrote:
> Hey,
> 
> On Wed, Jul 11, 2012 at 03:42:20PM +0100, Daniel P. Berrange wrote:
> > On Wed, Jul 11, 2012 at 10:23:21AM -0400, Cole Robinson wrote:
> > > I think this comes from rbd support, from configure.ac:
> > > 
> > > LIBRBD_LIBS="-lrbd -lrados -lcrypto"
> > > 
> > > from this commit:
> > > 
> > > http://libvirt.org/git/?p=libvirt.git;a=commit;h=74951eadef85e2d100c7dc7bd9ae1093fbda722f
> > > 
> > > What's missing here? RPM BuildRequires, configure change, ...?
> > 
> > If rbd is include '-lcrypto' in its pkgconfig line, then its
> > RPM is responsible for ensuring BuildRequires is set in its
> > own -devel package. So sounds like there's BR missing there.
> 
> ceph-devel does not seem to come with a pkgconfig file, and the LIBRBD_LIBS
> line Cole quoted comes from libvirt's own configure.ac. I've checked with
> ldd that nor librbd nor librados link with libcrypto.

Ah, I see that now, in configure.ac we have

        LIBRBD_LIBS="-lrbd -lrados -lcrypto"

I vote for just removing the '-lcrypto' line from configure.ac then.

> If libcrypto is needed for rbd support, then libvirt should check itself
> that libcrypto is present.  All of this would indeed be much simpler if
> ceph shipped a pkgconfig file...

Yeah, I despair everytime I find a modern library that does not use
pkgconfig :-(


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]