[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] configure: rbd doesn't need -lcrypto



See https://www.redhat.com/archives/libvir-list/2012-July/msg00493.html

Basically building against librbd doesn't seem to actually require -lcrypto.

Also report the rbd linker flags in configure output

Signed-off-by: Cole Robinson <crobinso redhat com>
---
 configure.ac |    8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index d45f4f1..ae814cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1999,7 +1999,7 @@ if test "$with_storage_rbd" = "yes" || test "$with_storage_rbd" = "check"; then
 
     if test "$LIBRBD_FOUND" = "yes"; then
         with_storage_rbd=yes
-        LIBRBD_LIBS="-lrbd -lrados -lcrypto"
+        LIBRBD_LIBS="-lrbd -lrados"
         AC_DEFINE_UNQUOTED([WITH_STORAGE_RBD], [1],
          [whether RBD backend for storage driver is enabled])
     else
@@ -2962,6 +2962,12 @@ AC_MSG_NOTICE([     xdr: $XDR_CFLAGS])
 else
 AC_MSG_NOTICE([     xdr: no])
 fi
+if test "$with_storage_rbd" = "yes" ; then
+AC_MSG_NOTICE([     rbd: $LIBRBD_LIBS])
+else
+AC_MSG_NOTICE([     rbd: no])
+fi
+
 AC_MSG_NOTICE([])
 AC_MSG_NOTICE([Test suite])
 AC_MSG_NOTICE([])
-- 
1.7.10.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]