[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Unable to startVM in Power PC



Hi,

 

Here is my xml file

 

<domain type='qemu' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>

  <name>Test</name>

  <uuid>aaec5748-56a9-e2fe-655c-c08ca3a4c097</uuid>

  <memory unit='KiB'>65536</memory>

  <currentMemory unit='KiB'>65536</currentMemory>

  <vcpu placement='static'>1</vcpu>

  <os>

    <type arch='i686' machine='ppce500v2'>hvm</type>

    <kernel>/boot/uImage-p2020rdb.bin</kernel>

    <initrd>/home/root/guest.rootfs.ext2.gz</initrd>

    <cmdline>root=/dev/ram rw console=ttyS0,115200</cmdline>

  </os>

  <features>

    <acpi/>

  </features>

  <clock offset='utc'/>

  <on_poweroff>destroy</on_poweroff>

  <on_reboot>restart</on_reboot>

  <on_crash>destroy</on_crash>

  <devices>

    <emulator>/usr/bin/qemu-system-ppc</emulator>

    <interface type='ethernet'>

      <mac address='52:54:00:dd:fa:40'/>

      <script path='/home/root/qemu-ifup'/>

      <model type='virtio'/>

    </interface>

    <serial type='tcp'>

      <source mode='bind' host='' service='4444'/>

      <protocol type='raw'/>

      <target port='0'/>

    </serial>

    <console type='tcp'>

      <source mode='bind' host='' service='4444'/>

      <protocol type='raw'/>

      <target type='serial' port='0'/>

    </console>

    <memballoon model='virtio'/>

  </devices>

  <qemu:commandline>

    <qemu:arg value='200M'/>

    <qemu:arg value='-mem-path'/>

    <qemu:arg value='/var/lib/hugetlbfs/pagesize-4MB'/>

    <qemu:arg value='-dtb'/>

    <qemu:arg value='/usr/share/qemu/ppce500v2.dtb'/>

  </qemu:commandline>

</domain>

 

 

While starting VM I am getting following error

root p2020rdb:~# virsh start Test

error: Failed to start domain Test

error: Unable to read from monitor: Connection reset by peer

 

#############################

Test.log Log file

############ ################

LC_ALL=C PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin HOME=/home/root USER=root LOGNAME=root /usr/bin/qemu-system-ppc -name Test -S -M ppce500v2 -m 256 -smp 1,sockets=1,cores=1,threads=1 -uuid aaec5748-56a9-e2fe-655c-c08ca3a4c097 -nographic -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/usr/local/var/lib/libvirt/qemu/Test.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -kernel /boot/uImage-p2020rdb.bin -initrd /home/root/guest.rootfs.ext2.gz -append root=/dev/ram rw console=ttyS0,115200 -device piix3-usb-uhci,id=usb,bus=pci,addr=0x1.0x2 -netdev tap,script=/home/root/qemu-ifup,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:dd:fa:40,bus=pci,addr=0x3 -chardev socket,id=charserial0,host=,port=4444,server,nowait -device isa-serial,chardev=charserial0,id=serial0 -device virtio-balloon-pci,id=balloon0,bus=pci,addr=0x4 -mem-path /var/lib/hugetlbfs/pagesize-4MB -dtb /usr/share/qemu/ppce500v2.dtb

Domain id=24 is tainted: high-privileges

Domain id=24 is tainted: custom-argv

Domain id=24 is tainted: shell-scripts

qemu-system-ppc: -device piix3-usb-uhci,id=usb,bus=pci,addr=0x1.0x2: Bus 'pci' not found

2012-07-19 09:06:25.215+0000: shutting down

 

Please help me regarding this issue

 

Regards,

Veera.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]