[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 03/13] Rewrite virAtomic APIs using GLib's atomic ops code



On 07/20/2012 12:36 AM, Hu Tao wrote:
>>> The `verify' lines cause building warnings:
>>>
>>> cc1: warnings being treated as errors
>>> util/virobject.c: In function 'virClassNew':
>>> util/virobject.c:74:99: error: nested extern declaration of '_gl_verify_function2' [-Wnested-externs]
>>
>> Which version of gcc?
>>
>> I'll have to see if I can come up with a solution in upstream gnulib
>> that expands verify() in such a way that works with -Wnested-externs.
> 
> $ gcc --version
> gcc (GCC) 4.5.1 20100924 (Red Hat 4.5.1-4)
> Copyright (C) 2010 Free Software Foundation, Inc.
> 
> 
> This is the gcc shipped with Fedora 14.

You _do_ realize that Fedora 14 is unsupported upstream (right now, the
oldest supported version is Fedora 16).  That said, I still have an F14
VM lying around, so I will try to reproduce this.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]