[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Preferred CPU model not allowed by hypervisor



Hi,

On Sat, Jul 21, 2012 at 04:46:18 -0500, Jared wrote:
> I'm having a weird problem where libvirt/qemu/kvm won't let me use the model
> processor I have defined in my domain's config file.  Instead, I get the
> error message in libvirtd.log that:
> 
> warning : x86Decode:1346 : Preferred CPU model Nehalem not allowed by
> hypervisor; closest supported model will be used
> 
> If I review the qemu log for that particular domain, I see that my CPU has
> been changed to this:
> 
> -cpu kvm64,+lahf_lm,+popcnt,+sse4.2,+sse4.1,+ssse3

The problem is libvirt that starts qemu-kvm with -nodefconfig (you can try
running qemu-kvm -nodefconfig -cpu \? and check the list of available CPUs),
which means /etc/qemu/target-x86_64.conf file is ignored by qemu-kvm. You will
need very recent qemu-kvm (at least 1.1) and libvirt (0.9.13 or newer), which
finally fixed this longstanding issue.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]