[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: don't export avahi syms when unused



On Mon, Jul 30, 2012 at 05:31:20PM -0600, Eric Blake wrote:
> Detected when building --without-avahi.
> 
> * src/libvirt_private.syms (virnetservermdns.h): Move...
> * src/libvirt_avahi.syms: ...to new file.
> * src/Makefile.am (USED_SYM_FILES, EXTRA_DIST): Use it.
> ---
> 
> I'm debating whether to push this under the build-breaker rule.
> Unfortunately, while this solved my build on an Ubuntu machine,
> I have other machines which are failing for other symbols (some
> SASL related, and one for xenLinuxDomainBlockStats), so it's
> probably better to fix everything instead of just half the problem.
> 
>  src/Makefile.am          |  7 ++++++-
>  src/libvirt_avahi.syms   | 13 +++++++++++++
>  src/libvirt_private.syms | 13 -------------
>  3 files changed, 19 insertions(+), 14 deletions(-)
>  create mode 100644 src/libvirt_avahi.syms

Reluctant ACK. I'm surprised I wrote it using HAVE_AVAHI.
I would be nice to change this so that the code in the
.c file is conditionalized, and the APIs still exist
providing a ENOSYS error or something.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]