[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] can't get right capabilities



Hi,

I am trying to use x86 machine to create VMs.
But one error occurs.

[root mcd kvm-test]# virsh create test.xml
error: Failed to create domain from test.xml
error: unknown OS type hvm

My xml file is as the following:

<domain type='kvm'>
      <name>test</name>
      <memory>524288</memory>
      <memorybacking>
          <hugepages/>
      </memorybacking>
      <vcpu>2</vcpu>
      <os>
          <type arch='x86_64' machine='pc'>hvm</type>
      </os>
      <features>
          <acpi/>
      </features>
      <clock offset='utc'/>
      <devices>
          <emulator>/usr/bin/qemu-system-x86_64</emulator>
          <disk type='file' device='disk' >
              <driver name='qemu' type='raw'/>
              <source file='/home/zhlbj/kvm-test/disk1'/>
              <target dev='sda' bus='scsi'/>
          </disk>
          <interface type='bridge'>
               <source bridge='virbr0'/>
               <mac address='52:54:00:19:bc:0c'/>
          </interface>
          <serial type='pty'>
             <target port='0'/>
          </serial>
          <console type='pty'>
             <target type='serial' port='0'/>
          </console>
          <memballoon model="none"/>
      </devices>
</domain>


I check kvm module, it is available.

[root mcd kvm-test]# lsmod |grep kvm
kvm_intel             119308  4
kvm                   344876  1 kvm_intel

But I tried the capabilities, it is not right.
There is no guest capabilities.

<capabilities>

  <host>
    <uuid>d4ff0166-0f8b-e111-ab17-78a277034000</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>Nehalem</model>
      <vendor>Intel</vendor>
      <topology sockets='1' cores='4' threads='1'/>
      <feature name='rdtscp'/>
      <feature name='avx'/>
      <feature name='osxsave'/>
      <feature name='xsave'/>
      <feature name='tsc-deadline'/>
      <feature name='x2apic'/>
      <feature name='pdcm'/>
      <feature name='xtpr'/>
      <feature name='tm2'/>
      <feature name='est'/>
      <feature name='smx'/>
      <feature name='vmx'/>
      <feature name='ds_cpl'/>
      <feature name='monitor'/>
      <feature name='dtes64'/>
      <feature name='pclmuldq'/>
      <feature name='pbe'/>
      <feature name='tm'/>
      <feature name='ht'/>
      <feature name='ss'/>
      <feature name='acpi'/>
      <feature name='ds'/>
      <feature name='vme'/>
    </cpu>
    <power_management>
      <suspend_mem/>
      <suspend_disk/>
      <suspend_hybrid/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
      </uri_transports>
    </migration_features>
    <secmodel>
      <model>selinux</model>
      <doi>0</doi>
    </secmodel>
  </host>

</capabilities>


This problem occurs some times.
When I tried to find this problem, it didn't occur.
Now it occurs again. It's a little strange.

Is there anything I miss?


--
Best Regards
Li

IBM LTC, China System&Technology Lab, Beijing


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]