[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: hoist qemu dependence on yajl to configure



On 06/13/2012 11:00 AM, Eric Blake wrote:
> Commit 6e769eba made it a runtime error if libvirt was compiled
> without yajl support but targets a new enough qemu.  But enough
> users are hitting this on self-compiled libvirt that it is worth
> erroring out at compilation time, rather than an obscure failure
> when trying to use the built executable.
> 
> * configure.ac: If qemu is requested and -version works, require
> yajl if qemu version is new enough.
> * src/qemu/qemu_capabilities.c (qemuCapsComputeCmdFlags): Add
> comment.
> ---

I did test that 'yum erase yajl-devel' followed by a fresh configure
with this patch did complain on my F17 box; then reinstalling yajl-devel
let configure proceed.

Caveat - my RHEL 5 box (more precisely, the disk that hosts my RHEL 5
disk image) is currently in storage, so I haven't actually tested that
this works on that older setup.  Since RHEL 5 doesn't have yajl-devel, I
would appreciate if someone can test that this change doesn't break
./configure with no options on that older setup.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]