[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/4] docs: fix 404 page when fetched from different location



On 06/21/2012 12:24 PM, Daniel P. Berrange wrote:
> On Thu, Jun 21, 2012 at 12:18:12PM +0200, Martin Kletzander wrote:
>> Error 404 page had relative paths specified for both the image and
>> stylesheets which caused a problem when requested URL included a
>> subfolder (e.g. http://libvirt.org/asdf/asdf ). This patch corrects
>> this behaviour.
>> ---
>>  docs/404.html.in |    5 ++++-
>>  1 files changed, 4 insertions(+), 1 deletions(-)
>>
>> diff --git a/docs/404.html.in b/docs/404.html.in
>> index 9363871..66e4c14 100644
>> --- a/docs/404.html.in
>> +++ b/docs/404.html.in
>> @@ -1,5 +1,8 @@
>>  <?xml version="1.0"?>
>>  <html>
>> +  <head>
>> +    <link rel="stylesheet" type="text/css" href="/main.css" />
>> +  </head>
> 
> The page.xsl already generates a <head> section with a <link> element.
> What you need todo is fix  site.xsl to use '/' as the href_base. In
> fact if we just used '/' as href_base, then we can remove the
> subsite.xsl entirely.
> 

I haven't noticed that, thanks. OK, so I deleted subsite.xsl, replaced
it with site.xsl, but internals/*.html are still generated with
../main.css, which is ok, but its not what I meant to achieve. The only
place where href_base is set to '../' is newapi.xsl, but that one is
used only for libvirt-api.xml if I read the rules and Makefiles correctly.

Anyway, I'll send a v2 for this.

> 
>>    <body>
>>      <h1>404 page not found</h1>
>>
>> @@ -15,7 +18,7 @@
>>      </ul>
>>
>>      <p class="image">
>> -      <img src="libvirtLogo404.png" alt="libvirt Logo"/>
>> +      <img src="/libvirtLogo404.png" alt="libvirt Logo"/>
>>      </p>
> 
> 
> Daniel
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]