[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH][libvirt-sandbox] configure: Require higher version of glib



On Fri, Jun 22, 2012 at 12:01:01PM +0200, Michal Privoznik wrote:
> On 21.06.2012 12:51, Daniel P. Berrange wrote:
> > On Thu, Jun 21, 2012 at 12:34:18PM +0200, Michal Privoznik wrote:
> >> Since commit cfd4460b we must require glib-2.32.0 at least
> >> because we are using g_value_set_schar which was introduced
> >> in that release.
> >> ---
> >>  configure.ac |    2 +-
> >>  1 files changed, 1 insertions(+), 1 deletions(-)
> >>
> >> diff --git a/configure.ac b/configure.ac
> >> index f8956c4..8d91440 100644
> >> --- a/configure.ac
> >> +++ b/configure.ac
> >> @@ -11,7 +11,7 @@ AC_CANONICAL_HOST
> >>  AM_SILENT_RULES([yes])
> >>  
> >>  GIO_UNIX_REQUIRED=2.28.0
> >> -GOBJECT_REQUIRED=2.28.0
> >> +GOBJECT_REQUIRED=2.32.0
> >>  LIBVIRT_GLIB_REQUIRED=0.0.4
> >>  LIBVIRT_GOBJECT_REQUIRED=0.0.7
> >>  GOBJECT_INTROSPECTION_REQUIRED=0.10.8
> > 
> > ACK, but can you update the RPM specfile to match too
> > 
> > Daniel
> > 
> 
> Okay, squashing this in:
> 
> diff --git a/libvirt-sandbox.spec.in b/libvirt-sandbox.spec.in
> index 77aede9..42970b2 100644
> --- a/libvirt-sandbox.spec.in
> +++ b/libvirt-sandbox.spec.in
> @@ -25,6 +25,7 @@ BuildRequires: libvirt-gobject-devel >= 0.0.7
>  BuildRequires: gobject-introspection-devel
>  %endif
>  BuildRequires: glibc-static
> +Requires: glib2-devel >= 2.32.0

BuildRequires....


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]