[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] util: combine three bools in virNetDevTapCreateInBridgePort into one flags

On 03/01/2012 01:48 PM, Laine Stump wrote:
> With an additional new bool added to determine whether or not to
> discourage the use of the supplied MAC address by the bridge itself,
> virNetDevTapCreateInBridgePort had three booleans (well, 2 bools and
> an int used as a bool) in the arg list, which made it increasingly
> difficult to follow what was going on. This patch combines those three
> into a single flags arg, which not only shortens the arg list, but
> makes it more self-documenting.
> ---
> Does this make more sense as a PATCH 2/1 to be associated with the
> first patch in this thread:
>   http://www.redhat.com/archives/libvir-list/2012-February/msg00760.html
> or should I squash them both together? (I'm leaning towards two
> separate patches, but could be convinced either way)

I'm fine with two patches.

I haven't reviewed the earlier post, but for this commit, you have my:


Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]