[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH v2] Removed more AMD-specific features from cpu64-rhel* models



We found few more AMD-specific features in cpu64-rhel* models that
made it impossible to start qemu guest on Intel host (with this
setting) even though qemu itself starts correctly with them.
This impacts one test, thus the fix in tests/cputestdata/.
---
 src/cpu/cpu_map.xml                                |    2 --
 .../cputestdata/x86-baseline-no-vendor-result.xml  |    3 +--
 2 files changed, 1 insertions(+), 4 deletions(-)

diff --git a/src/cpu/cpu_map.xml b/src/cpu/cpu_map.xml
index 7ef230e..6a6603b 100644
--- a/src/cpu/cpu_map.xml
+++ b/src/cpu/cpu_map.xml
@@ -347,7 +347,6 @@
     </model>

     <model name='cpu64-rhel6'>
-      <feature name='abm'/>
       <feature name='apic'/>
       <feature name='clflush'/>
       <feature name='cmov'/>
@@ -373,7 +372,6 @@
       <feature name='sse'/>
       <feature name='sse2'/>
       <feature name='pni'/>
-      <feature name='sse4a'/>
       <feature name='syscall'/>
       <feature name='tsc'/>
     </model>
diff --git a/tests/cputestdata/x86-baseline-no-vendor-result.xml b/tests/cputestdata/x86-baseline-no-vendor-result.xml
index 4b4921c..00e03b2 100644
--- a/tests/cputestdata/x86-baseline-no-vendor-result.xml
+++ b/tests/cputestdata/x86-baseline-no-vendor-result.xml
@@ -1,4 +1,3 @@
 <cpu mode='custom' match='exact'>
-  <model fallback='allow'>kvm64</model>
-  <feature policy='require' name='lahf_lm'/>
+  <model fallback='allow'>cpu64-rhel6</model>
 </cpu>
--
1.7.3.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]