[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH v3 0/3] usb devices with same vendorID, productID hotplug support



https://bugzilla.redhat.com/show_bug.cgi?id=815755

The set of patch tries to fix the issue when multiple usb devices with
same idVendor, idProduct are availible on host,  the usb device with
lowest bus:device will be attached to guest if usb xml file is given like
this:

<hostdev mode='subsystem' type='usb' managed='yes'>
  <source>
    <vendor id='0x15e1'/>
    <product id='0x2007'/>
  </source>
</hostdev>

The reason is that the usb hotplug function searchs usb device in system files
to match vendor and product id, the file with lowest number is always found
first.

After fix, in this case, libvirt will report an error like:
# virsh attach-device rhel6u1 /tmp/usb.xml
error: Failed to attach device from /tmp/usb.xml
error: operation failed: multiple USB devices for 15e1:2007, use <address> to specify one

At the same time, the usb part of domain initilization is also updated in patch 2/3

These patches also fix the problem when using the following xml, the usb device
could be hotplugged in two domains without raising errors

<hostdev mode='subsystem' type='usb' managed='yes'>
  <source>
    <address bus='6' device='7'/>
  </source>
</hostdev>

# virsh attach-device rhel6u12nd /tmp/usb_by_bus.xml
error: Failed to attach device from /tmp/usb_by_bus.xml
error: Requested operation is not valid: USB device 006:007 is in use by domain rhel6u1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]