[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 5/5] numad: Add buildRequires of numactl-devel



On 2012年05月09日 00:04, Osier Yang wrote:
As libnuma's API is used to set memory policy.

Ah, no. The following was ignored by "git am".

---
@Eric, I don't see numactl-devel in FC17 provides numad binary,
(strange if it provides, :), So I didn't change like what you
suggested:

%if %{with_numad}
%if 0%{?fedora} >= 17
BuildRequires: numactl-devel
%else
BuildRequires: numad
%endif

---
  libvirt.spec.in |    4 ++++
  1 files changed, 4 insertions(+), 0 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 95d8af4..f7764e8 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -457,8 +457,12 @@ BuildRequires: gawk
  BuildRequires: scrub

  %if %{with_numad}
+%if 0%{?fedora}>= 17
+BuildRequires: numactl-devel
+%else
  BuildRequires: numad
  %endif
+%endif

But anyway I blindly made a mistake with in the midnight.


  %description
  Libvirt is a C toolkit to interact with the virtualization capabilities


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]