[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 01/10] Only build server side drivers as modules



On Mon, May 21, 2012 at 08:59:09PM +0100, Daniel P. Berrange wrote:
> diff --git a/src/Makefile.am b/src/Makefile.am
> index e9621c1..8ad6644 100644
> --- a/src/Makefile.am
> +++ b/src/Makefile.am

>  libvirt_driver_xenapi_la_CFLAGS = $(LIBXENSERVER_CFLAGS) $(LIBCURL_CFLAGS) \
>  		-I$(top_srcdir)/src/conf $(AM_CFLAGS)
>  libvirt_driver_xenapi_la_LDFLAGS = $(AM_LDFLAGS)
>  libvirt_driver_xenapi_la_LIBADD = $(LIBXENSERVER_LIBS) $(LIBCURL_LIBS)
> -if WITH_DRIVER_MODULES
>  libvirt_driver_xenapi_la_LIBADD += ../gnulib/lib/libgnu.la
>  libvirt_driver_xenapi_la_LDFLAGS += -module -avoid-version
> -endif
>  libvirt_driver_xenapi_la_SOURCES = $(XENAPI_DRIVER_SOURCES)
>  endif

This is the cause of the XenAPI build failure noted in patch 3.
Those 2 lines inside the if WITH_DRIVER_MODULES should have
also been deleted as they were for other entries, eg:

>  libvirt_driver_esx_la_CFLAGS = $(LIBCURL_CFLAGS) \
>  		-I$(top_srcdir)/src/conf -I$(top_srcdir)/src/vmx $(AM_CFLAGS)
>  libvirt_driver_esx_la_LDFLAGS = $(AM_LDFLAGS)
>  libvirt_driver_esx_la_LIBADD = $(LIBCURL_LIBS)
> -if WITH_DRIVER_MODULES
> -libvirt_driver_esx_la_LIBADD += ../gnulib/lib/libgnu.la
> -libvirt_driver_esx_la_LDFLAGS += -module -avoid-version
> -endif
>  libvirt_driver_esx_la_SOURCES = $(ESX_DRIVER_SOURCES)
>  libvirt_driver_esx_la_DEPENDENCIES = $(ESX_DRIVER_GENERATED)
>  endif


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]