[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 00/10 v2] Enable loadable modules for libvirtd



On Mon, May 21, 2012 at 08:59:08PM +0100, Daniel P. Berrange wrote:
> A simple rebase of
> 
>   https://www.redhat.com/archives/libvir-list/2012-April/msg00045.html
> 
> For a long timer we've had the ability to build each libvirt
> driver as a loadable module. We have never used this by default
> and as a result it constantly bit-rots.
> 
> This series fixes various bugs, and then enables it by default
> in configure. It also makes the PRMs use the loadable modules,
> adding new new sub-RPMs for each module. We can now finally
> install minimal libvirt binaries for each hypervisor.
> 
> ie  yum install libvirt-daemon-kvm
> 
>  will not pull in Xen libraries!
> 
> Changes in v2:
> 
>  - Fix build with dtrace
>  - Rebase to latest GIT master

  ACK on the general idea, I see Eric reviewed the patches already.
I would suggest we add a note (mainly in docs/drivers.html.in and
possibly in docs/internals.html.in) stating that the APIs used by
the drivers are internal and not part of the ABI guarantees even
if they are distributed as separate shared library.
  Historically we had punted on enabling shared libraries to avoid
proprietary drivers, now the daemon runs as GPL by the virtue of linking
with GPL libraries so that may discourage such behaviour but we should
at least make clear that we won't make shipping out of source drivers
an easy task :)

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]