[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Error when running "virsh version" and "virt-manager"



Hello all,

I have pulled the latest changes from the upstream libvirt repo as of today morning.

I have then self-built and installed libvirt using the following commands (machine OS RHEL6.2):

1) ./autogen.sh --system --enable-compile-warnings=error
2) make
3) make install
4) service libvirtd restart



At this point when I run the command "virsh version" I see the following output:

Compiled against library: libvir 0.9.12
Using library: libvir 0.9.12
Using API: QEMU 0.9.12
error: failed to get the hypervisor version
error: internal error Cannot find suitable emulator for x86_64



Some debug commands and their output:

[root c6100o libvirt]# rpm -qa | grep qemu-kvm
qemu-kvm-0.12.1.2-2.209.el6.x86_64

[root c6100o libvirt]# whereis qemu-kvm
qemu-kvm: /usr/libexec/qemu-kvm /usr/share/qemu-kvm /usr/share/man/man1/qemu-kvm.1.gz

[root c6100o libvirt]# which virsh
/usr/bin/virsh

[root c6100o libvirt]# which libvirtd
/usr/sbin/libvirtd


Please may I ask for help in order to resolve this issue?
-- 
Many Thanks,
Regards,
Shradha Shah


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]