[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Error when running "virsh version" and "virt-manager"



The output of virsh capabilities is:

[root c6100o bin]# virsh capabilities
<capabilities>

  <host>
    <uuid>44454c4c-3500-1058-8030-b4c04f33354a</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>Westmere</model>
      <vendor>Intel</vendor>
      <topology sockets='1' cores='4' threads='2'/>
      <feature name='rdtscp'/>
      <feature name='pdpe1gb'/>
      <feature name='dca'/>
      <feature name='pdcm'/>
      <feature name='xtpr'/>
      <feature name='tm2'/>
      <feature name='est'/>
      <feature name='smx'/>
      <feature name='vmx'/>
      <feature name='ds_cpl'/>
      <feature name='monitor'/>
      <feature name='dtes64'/>
      <feature name='pclmuldq'/>
      <feature name='pbe'/>
      <feature name='tm'/>
      <feature name='ht'/>
      <feature name='ss'/>
      <feature name='acpi'/>
      <feature name='ds'/>
      <feature name='vme'/>
    </cpu>
    <power_management>
      <suspend_disk/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
      </uri_transports>
    </migration_features>
  </host>

</capabilities>

Also the log from /var/log/libvirt/libvirtd.log says:

2012-05-29 09:55:38.801+0000: 24292: error : qemuCapsComputeCmdFlags:1215 : unsupported configuration: this qemu binary requires libvirt to be compiled with yajl
2012-05-29 09:55:38.806+0000: 24292: error : qemuCapsComputeCmdFlags:1215 : unsupported configuration: this qemu binary requires libvirt to be compiled with yajl
2012-05-29 09:57:57.438+0000: 24287: error : qemuCapsExtractVersion:1566 : internal error Cannot find suitable emulator for x86_64

I created a syslink "/usr/bin/qemu-system-x86_64" to /usr/libexec/qemu-kvm and I still see the issue.

Many Thanks,
Regards,
Shradha Shah

On 05/29/2012 05:13 AM, Osier Yang wrote:
> On 2012年05月28日 20:27, Shradha Shah wrote:
>> At this point when I run the command "virsh version" I see the following output:
>>
>> Compiled against library: libvir 0.9.12
>> Using library: libvir 0.9.12
>> Using API: QEMU 0.9.12
>> error: failed to get the hypervisor version
>> error: internal error Cannot find suitable emulator for x86_64
> 
> What's the output of "virsh capabilities"?
> 
> 
> Osier


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]