[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] dhcp6, radvd, ip6tables, etc. (update)



On 11/01/2012 10:08 AM, Dave Allan wrote:
On Thu, Nov 01, 2012 at 07:25:45AM -0400, Gene Czarcinski wrote:

Doing some looking, it appears that RHEL6.3 uses libvirt-0.8.7 and
CentOS6.3 uses libvirt-0.9.10.  I can see some group wanting to
Just for the record, RHEL6.3 uses libvirt-0.9.10.


OK, as far as I am concerned, the critical thing is what parameters will work with dnsmasq-2.48 so that if libvirt-1.0.0 was rebuilt and installed on (for example) CentOS 6.3, that dnsmasq-2.48 will work.

First of all, at a minimum, to support DHCPv6, you must be running dnsmasq-2.64 or dnsmasq-2.63+patches [those patches may fit on earlier versions of dnsmasq, I have no idea]. But, if you do not specify any DHCPv6 but just the regular IPv4 stuff plus listen-address=<IPv6-address>, will dnsmasq work with the changes I have made to libvirt that puts the dnsmasq parameters into a conf-file.

I am in the process of creating a CentOS 6.3 virtual system. I will then feed the dnsmasq on that system slightly modified versions of various conf-files created under libvirt to see which are going to give dnsmasq indigestion.

I still believe that for someone to go to the effort of getting (lets say) libvirt-1.0.0 built, installed and running on CentOS 6.3, then requiring that dnsmasq-2.64 also be installed is not that big a deal ... but that is just my opinion.

Gene


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]