[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] dnsmasq-248 (CentOS/RHEL) compatibility



On 11/02/2012 09:22 AM, Daniel P. Berrange wrote:
On Fri, Nov 02, 2012 at 08:57:04AM -0400, Gene Czarcinski wrote:
There are currently three significant libvirt patches I am involved with:

1. Change so that dnsmasq parameters are in a conf file instead of
on the command line.

2. A small patch to add dnsmasq parameter interface=

3. A significant patch to add DHCPv6 support to libvirt.

A concern has been raised about the compatibility of my patches with
dnsmasq-2.48 which is the version on CentOS 6 and RHEL 6.  While
something like libvirt-1.0.0 is not officially supported, there is a
strong desire not to get in the way of individuals back-porting it.

Plan A:  Install CentOS 6.3 into a virtual guest.  Apparently, the
current virt-manager has some problems running CentOS 6.3.  Since I
was here to drain a swap, I decided not to go after this alligator.

Plan B:  Get a the src.rpm for dnsmasq-2.48 from CentOS and build it
on Fedora 17.  Then, using a Fedora 17  virtual guest, downgrade
install dnsmasq-2.48 on it.

I then took four of my virtual dnsmasq conf-files than I use,
slightly modify them to use interface=eth2 and common pid,
hostsfile, addnhosts, and leases files.  I then fed each of these
configuration files to dnsmasq-2.48.  Everything worked except for
the one which had an IPv6 dhcp-range specified.  That was not
surprising dnsmasq-2.48 only supports IPv6 for dns.

If someone has some additional tests they would like run, please say so.

My recommendation:  Incorporate my patches [when I finish the DHCPv6
one and resubmit the others].  Add (somewhere?) a warning to
backporters that they will need to update their dnsmasq packages to
actually do DHCPv6 but otherwise, earlier versions such as
dnsmasq-2.48 will be compatible.
If it is merely a case that RHEL-6 users won't be able to take
advantage of new IPv6 related features, then this is fine for
us. When we talk about compatibility all we're worried about
is existing users loosing existing features.  If they want
new features, it is perfectly reasonable to require them to
upgrade

A position I agree with 100%.

As a matter of fact, you need dnsmasq-2.64 or dnsmasq-2.63 with a couple small patches to use DHCPv6 at all. Without these patches, it just does not work.

Gene


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]