[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] dnsmasq supporting RA instead of radvd patch



On 11/07/2012 04:16 PM, Eric Blake wrote:
> On 11/07/2012 02:05 PM, Gene Czarcinski wrote:
>> As I was doing this, I also looked through the libvirt.spec file. My,
>> what a wonderful example of wizardly that is.  Anyway, I thought some
>> updates may be in ortder:
>>
>> - increase the minimum version for dnsmasq from 2.41 to 2.48.
> That's probably safe, since it still works for RHEL 5.9.

Actually, RHEL 5.9 (and therefore CentOS 5) is stuck at dnsmasq-2.45,
and there's very little chance it will ever be rebased again.

So if the minimum version is going to be increased, it should be done
conditionally according to the release version.

>
>> - why is radvd required for rpmbuild?
> So that ./configure finds the radvd binaries, and encodes the correct
> location into the built libvirt, for the case where libvirt will be
> using radvd.  The dependency makes sense for distros where we plan on
> using radvd, but can be made conditional so that we skip it on distros
> where using dnsmasq alone is sufficient.

BTW, we'll want to do some reasonable testing of this replacement before
foisting it on everyone.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]