[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] virsh: add aliases 'boot', 'stop', and 'restart'



Daniel P. Berrange wrote:
> On Mon, Nov 05, 2012 at 12:59:16PM -0700, Eric Blake wrote:
>   
>> https://bugzilla.redhat.com/show_bug.cgi?id=873344 suggested that
>> the grouping 'boot', 'shutdown', 'reboot'; as well as the grouping
>> 'start', 'stop', 'restart'; might be easier to remember than the
>> current mix of 'start', 'shutdown', 'reboot'.
>>
>> * tools/virsh-domain.c (domManagementCmds): Add other command names.
>> * tools/virsh.pod (start, shutdown, reboot): Document the aliases.
>> ---
>>
>> This patch documents both spellings.  An alternative would be to
>> leave the alternate spellings as hidden aliases (virsh has support
>> for that), but still mention them in virsh.pod (see how we did an
>> alias for nodedev-dettach, for reference).
>>     
>
> NACK to this patch. I think the current command names are good.
> Creating duplicates will make life worse. First, it creates
> divergance from the similarly named commands for networks,
> storage and other objects.

Hmm, that is a very good observation, one I hadn't considered.  Agreed
that consistency with other commands is certainly important, where
'booting' a network e.g. is not very intuitive.

Regards,
Jim

>  It also means scripts written again
> the new commands will not work with existing libvirt.
>
> I actually think that shutdown & reboot are *better* names
> than restart and stop.
>
> If we wanted to replace any existing names, then the 'create'
> and 'destroy' names are the ones to replace, and for those I
> would expect to use 'boot' and 'stop'. I still don't thin
> we should do that either, due to creating inconsistency with
> other commands.
>
> Daniel
>   


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]