[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] problems with current libvirt and qemu-kvm



On 11/30/2012 03:24 AM, Daniel P. Berrange wrote:
On Thu, Nov 29, 2012 at 03:48:52PM -0500, Gene Czarcinski wrote:
When I rebased my DHCPv6, etc. patches, I did that not only on to of
Laine Stump's dnsmasq-capabiliotes/bind-dynamic updates but I also
rebased to "current" git master.

Well, the problem with the large number/frequent RTR-ADVERT syslog
messages from dnsmasq that I had previously seen were fixed ... they
stopped and dnsmasq produced expected results.  But, starting
virt-manager hung and there were new error messages in syslog about
"internal error cannot find suitable emulator for X86_64.
Until I pushed the patches from Victor yesterday, libvirt GIT was
broken when used against QEMU GIT. The effect was that libvirt
could not detect any QEMU binaries. So if you're using latest QEMU
GIT that might be what you've hit.


No, not the latest ... qemu-1.0.1-2.fc17.

But, this problem is getting more than a bit strange.

I have two systems which are pretty near identical (one id AMD-6-core and the other is AMD-8-core). They have the same kernel, the same libvirt, qemu, virt-manager, kernel, dnsmasq.

The "problem system" only has the RTR-ADVERT problem with one network definition! [IPv4 with DHCP and IPv6 with SLAAC]. Destroy that network and start another with different addresses but the same specification and no problems. The is one difference I need to check ... the problem network is autostarted.

I just installed the libvirt version that has a problem with qemu. I did not bother trying virt-manage since I just noticed a bunch of really strange syslog messages from libvirtd "unknown OS type hvm" so I downgraded back to something that works.

The last update I have listed in the git-log is b7aba48bcaf315c27430a7d0edf8ff702d293527 and that one changed src/conf/domain_conf.c.

I am going to give two things a try:

1. Back off the top few commits that hist domain stuff and

2. Try do a pull to update my copy of libvirt's git.

About the only thing I am sure of is I believe that the three patches I submitted and Laine's three patches for bind-dynamic are not the problem ... they are also applied to the version that works and only deal with network stuff.

Gene


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]