[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: avoid -Wno-format on new-enough gcc



On 10/02/2012 09:35 AM, Jiri Denemark wrote:
> On Tue, Oct 02, 2012 at 08:55:45 -0600, Eric Blake wrote:
>> Commit c579d6b added a sledgehammer to silence spurious warnings from
>> gcc 4.2, but in the process, it also silenced useful warnings from
>> newer gcc (such as 4.4).  As a result, a bug slipped in to commit 0caccb58.
>>
>> Tested with FreeBSD (gcc 4.2.1), RHEL 6.3 (gcc 4.4), and F17 (gcc 4.7.2).
>>
>> * m4/virt-compile-warnings.m4 (-Wno-format): Probe for the actual
>> spurious message, to once again allow gcc 4.4 to use -Wformat.
>> ---
>>  m4/virt-compile-warnings.m4 | 19 ++++++++++++++++++-
>>  1 file changed, 18 insertions(+), 1 deletion(-)
> 
> ACK

Thanks; pushed.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]