[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [libvirt-glib 1/2] spec: Get min libvirt version from configure.ac



The minimum libvirt version we need is duplicated in configure.ac
and libvirt.spec.in. Since libvirt.spec.in already gets some variables
substituted, we can also substitute LIBVIRT_REQUIRED to avoid the
duplication.
---
 configure.ac         | 1 +
 libvirt-glib.spec.in | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 7262322..369b368 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AC_CANONICAL_HOST
 AM_SILENT_RULES([yes])
 
 LIBVIRT_REQUIRED=0.9.10
+AC_SUBST([LIBVIRT_REQUIRED]) dnl used in the .spec file
 GLIB2_REQUIRED=2.22.0
 GOBJECT2_REQUIRED=2.10.0
 GIO_REQUIRED=2.10.0
diff --git a/libvirt-glib.spec.in b/libvirt-glib.spec.in
index e312926..f10c38a 100644
--- a/libvirt-glib.spec.in
+++ b/libvirt-glib.spec.in
@@ -18,7 +18,7 @@
 %endif
 %define with_vala %{with_introspection}
 
-%define libvirt_version 0.9.10
+%define libvirt_version @LIBVIRT_REQUIRED@
 
 Name: @PACKAGE@
 Version: @VERSION@
-- 
1.7.12.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]