[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [libvirt-php] Function calls blocking on Ubuntu 12.04



Dear List,

Please note I am not subscribed to this list.
I just wanted to state my problem, and will wait for a fix when it comes.

I have sucessfully compiled libvirt-php-0.4.5 on Ubuntu 12.04. I ran into some problems when
using the library in simple php code, specifically trying to retrieve a screenshot.

1. libvirt_domain_get_screenshot_api returns a PHP fatal about it not being defined ?!?
I have not looked into this at all. It was the first of the two I tried, and went on for the other :)

2. libvirt_domain_get_screenshot blocks forever
I investigated this one, as from my debug logging, I could see things were going right. My browser just never
finishes loading. I traced it down vnc.c on line x where a loop is started.
The loop never seems to finish (unsure why though), and commenting out the loop fixes my problem.


With kind regards,
Rory Slegtenhorst
rory dot slegtenhorst at gmail dot com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]