[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] spec: Add runtime requirement for libssh2



libssh2 unfortunately doesn't support symbol versioning so RPM can't
figure out what version is needed for the currently installed libvirt
package. This patch adds a runtime requirement, so that the correct
version of libssh2 can be installed along with libvirt.
---
 libvirt.spec.in | 1 +
 1 file changed, 1 insertion(+)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 75623eb..bc6a1af 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -500,6 +500,7 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 %if %{with_phyp} || %{with_libssh2_transport}
 %if %{with_libssh2_transport}
 BuildRequires: libssh2-devel >= 1.3.0
+Requires: libssh2 >= 1.3.0
 %else
 BuildRequires: libssh2-devel
 %endif
-- 
1.7.12.3


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]