[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] spec: Require newer sanlock on recent distros



On 10/16/2012 12:55 PM, Jiri Denemark wrote:
> Make sure libvirt is build with sanlock >= 2.4 on distros that are new
> enough to provide it.
> ---
>  libvirt.spec.in | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/libvirt.spec.in b/libvirt.spec.in
> index 75623eb..15c6b39 100644
> --- a/libvirt.spec.in
> +++ b/libvirt.spec.in
> @@ -410,8 +410,14 @@ BuildRequires: libpciaccess-devel >= 0.10.9
>  BuildRequires: yajl-devel
>  %endif
>  %if %{with_sanlock}
> +# make sure libvirt is built with new enough sanlock on
> +# distros that have it; required for on_lockfailure
> +%if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
> +BuildRequires: sanlock-devel >= 2.4
> +%else
>  BuildRequires: sanlock-devel >= 1.8
>  %endif
> +%endif
>  %if %{with_libpcap}
>  BuildRequires: libpcap-devel
>  %endif
> 

ACK,

Martin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]