[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] spec: Fix dependency for lock-sanlock subpackage



This should not make a big difference in real world since libvirt-daemon,
which is already required by libvirt-lock-sanlock, requires
libvirt-client and thus libvirt-lock-sanlock gets this dependency
transitively. However, since libvirt-lock-sanlock contains
sanlock_helper binary linked to libvirt.so, we should start requiring
libvirt-client directly.
---
 libvirt.spec.in | 1 +
 1 file changed, 1 insertion(+)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 2f3e829..511949e 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -1029,24 +1029,25 @@ Include header files & development libraries for the libvirt C library.
 %if %{with_sanlock}
 %package lock-sanlock
 Summary: Sanlock lock manager plugin for QEMU driver
 Group: Development/Libraries
 %if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
 Requires: sanlock >= 2.4
 %else
 Requires: sanlock >= 1.8
 %endif
 #for virt-sanlock-cleanup require augeas
 Requires: augeas
 Requires: %{name}-daemon = %{version}-%{release}
+Requires: %{name}-client = %{version}-%{release}
 
 %description lock-sanlock
 Includes the Sanlock lock manager plugin for the QEMU
 driver
 %endif
 
 %if %{with_python}
 %package python
 Summary: Python bindings for the libvirt library
 Group: Development/Libraries
 Requires: %{name}-client = %{version}-%{release}
 
-- 
1.7.12.3


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]