[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] 0.10.2 virtualport profileid (802.1Qbh) malformed



Hi,

I've just upgraded a test libvirtd host to 0.10.2 from 0.9.4 to be able to make use of the new 'virsh net-update add portgroup' live updates, however can't get my private/802.1Qbh interfaces working at all after the upgrade.

Trying to start an existing domain or install a new domain after the upgrade gives:
	"ERROR internal error corrupted profileid string"
and a corresponding error in the libvirtd log:
	"error : virNetDevVPortProfileMerge:381 : internal error corrupted profileid string"

I've tried all sorts of profileid combinations and tried defining the virtualport in the domain instead of in the network, to no avail.  The source indicates this is to do with a malformed (not null terminated) profile id when merging the port profile.  Why would this be happening?  Any hints how to debug it?

My example network definition:
    <network>
      <name>testnet</name>
      <uuid>76d32a2d-8433-6873-9c15-cdae30e7a632</uuid>
      <forward dev='eth1' mode='private'>
        <interface dev='eth1'/>
        <interface dev='eth2'/>
        <interface dev='eth3'/>
        ...
      </forward>
      <portgroup name='server1' default='yes'>
        <virtualport type='802.1Qbh'>
          <parameters profileid='profile-server1'/>
        </virtualport>
      </portgroup>
      <portgroup name='server2'>
        <virtualport type='802.1Qbh'>
          <parameters profileid='profile-server2'/>
        </virtualport>
      </portgroup>
      <portgroup name='server3'>
        <virtualport type='802.1Qbh'>
          <parameters profileid='profile-server3'/>
        </virtualport>
      </portgroup>
    </network>
and a domain definition which throws an error on start-up:
    <interface type='network'>
      <mac address='52:54:00:d1:94:5f'/>
      <source network='testnet' portgroup='server1'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>

Tom



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]