[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] Fix disabling of apparmor security driver



When using --without-apparmor --without-secdriver-apparmor, configure
will fail saying that AppArmor development package must be installed.
This is caused by a small bug in --with-secdriver-apparmor handling in
configure.ac which treats --without-secdriver-apparmor as if the user
had requested to enable apparmor.
---
 configure.ac | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 13967e9..6ffcb03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1562,7 +1562,8 @@ AC_ARG_WITH([secdriver-apparmor],
 if test "$with_apparmor" != "yes" ; then
   if test "$with_secdriver_apparmor" = "check" ; then
     with_secdriver_apparmor=no
-  else
+  fi
+  if test "$with_secdriver_apparmor" != "no" ; then
     AC_MSG_ERROR([You must install the AppArmor development package in order to compile libvirt])
   fi
 else
-- 
1.7.12.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]