[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: require netcf-0.2.2 when installing on Fedora18+



On 09/04/2012 01:17 PM, Eric Blake wrote:
> On 09/04/2012 11:10 AM, Laine Stump wrote:
>> A previous patch forced libnl-3 and netcf-0.2.2 (which itself requires
>> libnl-3) when *building* for Fedora 18+ (and RHEL 7+), but the
>> install-time Requires: for netcf has always been implicit due to
>> libvirtd linking with libnetcf.so. However, the since the API of netcf
>> didn't change when it was rebuilt to use libnl-3, the internal library
>> version didn't change either, making it possible (from rpm's point of
>> view) to upgrade libvirt without upgrading netcf (in reality, that
>> leads to a segfault - see
>> https://bugzilla.redhat.com/show_bug.cgi?id=853381).
>>
>> The solution is to put an explicit Requires: line in libvirt's
>> specfile for fedora >= 18 and rhel >= 7.
>> ---
>>  libvirt.spec.in | 3 +++
>>  1 file changed, 3 insertions(+)
> ACK.
>

Thanks. Pushed - we should push this same change into the f18 and
rawhide builds of libvirt on Fedora (there's even an appropriate BZ, but
bugzilla is currently down so I'll have to make a reminder on my todo
list to update it later).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]