[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Compile libvirt on Solaris



On Tue, Sep 04, 2012 at 04:26:55AM +0000, Yang Zhou (yangzho) wrote:
> Hi Experts,
> 
> I am compiling libvirt 0.9.9 on Solaris 9. But got following errors when run "./configure --with-esx --with-qemu"
> -------------------------------------------------------------------------------------------------------
> checking for library containing dlopen... -ldl
> checking for xen_vm_start in -lxenserver... no
> checking for libxl_domain_create_new in -lxenlight... no
> checking for xs_read in -lxenstore... no
> checking linux/kvm.h usability... no
> checking linux/kvm.h presence... no
> checking for linux/kvm.h... no
> checking for shell that supports <> redirection... /bin/sh
> checking linux/param.h usability... no
> checking linux/param.h presence... no
> checking for linux/param.h... no
> configure: error: You must install kernel-headers in order to compile libvirt with QEMU or LXC support
> bash-2.05$
> ----------------------------------------------------------------------------------------------------
> 
> After look at configure, it's found the headers of linux/param.h,
> linux/sockios.h. linux/if_bridge.h and linux/if_tun.h are
> required. Obviously these files are missing on Solaris platform. Anybody
> can help how to solve this issue?

  I'm not sure we still have an active maintainer on Solaris, John Levon
didn't posted here for ages ...

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]