[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 01/20] Add a virBitmapCopy API



On 09/12/2012 10:22 AM, Daniel P. Berrange wrote:
>>
>> This requires you to pre-create the copy, so a better name might be
>> virBitmapCopyInto(), and then rebase Hu's patch, so that his function
>> signature:
>>

> Actually I think my function has the right name already. Functions
> which create new instances should have 'New' in their name, eg
> 
>     virBitmapPtr virBitmapNewCopy(virBitmapPtr src)
> 
> Unless you object to this suggestion, I'll push my patch and let
> Hu rebase against it.

Yes, your alternate proposal of how to do the new naming makes sense, so
ACK to your patch going in as-is.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]