[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-java] Upload 0.4.8 to central Maven repository



On 09/13/2012 02:19 PM, Daniel Veillard wrote:
On Mon, Sep 10, 2012 at 03:46:43PM +0200, Wido den Hollander wrote:
On 09/10/2012 03:23 PM, Daniel Veillard wrote:
On Mon, Sep 10, 2012 at 03:00:57PM +0200, Wido den Hollander wrote:
On 09/10/2012 02:29 PM, Daniel Veillard wrote:
any idea how to tell the main maven site to refetch ? Even though we
added the checksums, http://search.maven.org still don't show 0.4.8


No, not a clue. It could be that it reads maven-metadata-local.xml
and sees that lastUpdated hasn't changed, so no need for any futher
searching?

I have a couple of things for 0.4.9 I want to fix, so when that
comes out, lastUpdated changes and hopefully maven will see that?

  yeah ... So what kind of changes do you have in mind ? To be honnest
I would like to make a release soon :-)


A couple of changes for creating and handling snapshots for
CloudStack, like re-defining snapshots which can't be done right
now.

Come to think of it, a 0.4.9 release under MIT would however be
preferable for CloudStack 4.0.

   Okay, you get it, it's out, can you check maven is working,
I had to do everything "by hand" as any attempt to fix the maven
rules in build.xml, use the scp, download jar which  it tries to
do all fail for various reasons. So manual edit of XMLs, of directories,
checksup of files ... if it works first time it's a miracle.
   So if you have knowledge of how a maven target rule should now
be done (yes i fetched maven-ant-tasks package for my system)


Thanks! It seems however that this libvirt-java release was build with Java 1.7 and that doesn't work under Java 1.6 which is being used in RHEL 6 and Ubuntu 12.04:

Caused by: java.lang.UnsupportedClassVersionError: org/libvirt/LibvirtException : Unsupported major.minor version 51.0

Could you rebuild with Java 1.6?

Also, the central Maven repo didn't pick up the change. It's still stuck at 0.4.7

-------------------------------------------
maven:
      [copy] Copying 1 file to /home/veillard/libvirt-java/target

BUILD FAILED
/home/veillard/libvirt-java/build.xml:119: Problem: failed to create
task or type antlib:org.apache.maven.artifact.ant:pom
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken
place.
No types or tasks have been defined in this namespace yet

This appears to be an antlib declaration.
Action: Check that the implementing library exists in one of:
         -/usr/share/ant/lib
         -/home/veillard/.ant/lib
         -a directory added on the command line with the -lib argument
-------------------------------------------

-> ls /usr/share/ant/lib
ant-bootstrap.jar  ant-jsch.jar    ant-junit.jar
ant.jar            ant-junit4.jar  ant-launcher.jar
-> rpm -ql maven-ant-tasks
/usr/share/doc/maven-ant-tasks-2.1.1
/usr/share/doc/maven-ant-tasks-2.1.1/DEPENDENCIES
/usr/share/doc/maven-ant-tasks-2.1.1/LICENSE
/usr/share/doc/maven-ant-tasks-2.1.1/NOTICE
/usr/share/doc/maven-ant-tasks-2.1.1/README.txt
/usr/share/java/maven-ant-tasks.jar
/usr/share/maven-fragments/maven-ant-tasks
/usr/share/maven-poms/JPP-maven-ant-tasks.pom
->

   I recognize my ignorance of this system, i would just love something
which works (using the scp exe allows me to pull/push from libvirt.org
without question asked, ant-jsch failed any way i tried to authenticate)
so I don't pull that many hairs each time i need to assemble a release :-)


I gave it a try on my system and it works when I use this URL for the maven-ant-tasks JAR: http://repo1.maven.org/maven2/org/apache/maven/maven-ant-tasks/2.1.3/maven-ant-tasks-2.1.3.jar

Obviously I couldn't try the scp to libvirt.org, but I noticed however that "scp.username" has already been set in build.properties while the build.xml also tries to query for it:

[input] skipping input as property scp.username has already been set.

While I had the "scp" part commented out I uncommented it and gave it a try to a local machine, I ran into the same issue. A bit of searching brought me to this on my Ubuntu machine:

$ cd /usr/share/ant/lib
$ ln -s ../../java/jsch.jar

I pushed a fix for both build.xml and build.properties to https://github.com/wido/libvirt-java/tree/maven

You might want to pull it.

Wido

   thanks in advance !

Daniel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]