[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Don't install legacy initscripts at same time as systemd ones



On Fri, Sep 21, 2012 at 11:24:31AM +0100, Daniel P. Berrange wrote:
> From: "Daniel P. Berrange" <berrange redhat com>
> 
> The Fedora policies don't want us installing the legacy initscripts
> in parallel with the systemd ones, so switch to only install the
> systemd unit
> 
> Signed-off-by: Daniel P. Berrange <berrange redhat com>
> ---
>  libvirt.spec.in | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/libvirt.spec.in b/libvirt.spec.in
> index 1192739..a392663 100644
> --- a/libvirt.spec.in
> +++ b/libvirt.spec.in
> @@ -1217,9 +1217,7 @@ of recent versions of Linux (and other OSes).
>  %define with_packager_version --with-packager-version="%{release}"
>  
>  %if %{with_systemd}
> -# We use 'systemd+redhat', so if someone installs upstart or
> -# legacy init scripts, they can still start libvirtd, etc
> -%define init_scripts --with-init_script=systemd+redhat
> +%define init_scripts --with-init_script=systemd
>  %else
>  %define init_scripts --with-init_script=redhat
>  %endif

  Okay, pushed !

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]