[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [RFC] [PATCH v3 1/6] add a configure option --with-fuse to prepare introduction of fuse support for libvirt lxc



于 2012年09月25日 02:24, Doug Goldstein 写道:
> On Mon, Sep 10, 2012 at 9:54 PM, Gao feng <gaofeng cn fujitsu com> wrote:
>> add a configure option --with-fuse to prepare introduction
>> of fuse support for libvirt lxc.
>>
>> With help from Daniel
>>
>> Signed-off-by: Gao feng <gaofeng cn fujitsu com>
>> ---
>>  configure.ac    |   35 +++++++++++++++++++++++++++++++++++
>>  libvirt.spec.in |    9 +++++++++
>>  2 files changed, 44 insertions(+), 0 deletions(-)
>>
>> diff --git a/configure.ac b/configure.ac
>> index 47a72b9..cc7de9d 100644
>> --- a/configure.ac
>> +++ b/configure.ac
>> @@ -1847,6 +1847,36 @@ AC_SUBST([CAPNG_CFLAGS])
>>  AC_SUBST([CAPNG_LIBS])
>>
>>
>> +dnl libfuse
>> +AC_ARG_WITH([fuse],
>> +  AC_HELP_STRING([--with-fuse], [use libfuse to proivde fuse filesystem support for libvirt lxc]),
>> +  [],
>> +  [with_fuse=check])
>> +dnl
>> +dnl This check looks for 'fuse'
>> +dnl
>> +FUSE_CFLAGS=
>> +FUSE_LIBS=
>> +if test "x$with_fuse" != "xno"; then
>> +  PKG_CHECK_MODULES([FUSE], [fuse],
> 
> Probably want to figure out your minimum supported version and check
> for at least that or newer.
> 

Thanks,I will check this.

>> +    [with_fuse=yes], [
>> +    if test "x$with_fuse" = "xcheck" ; then
>> +        with_fuse=no
>> +    else
>> +        AC_MSG_ERROR(
>> +          [You must install fuse-devel to compile libvirt])
> 
> Very Fedora/RHEL-y message. Probably better to be a bit more abstract.
> See other messages in confugure.ac for an example.
> 

Get it,will modify it.


> Other than the 2 small comments, it looks fine.

Thanks for your comments!



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]