[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 0/2] Fixed QEMU 1.0.1 support



On Tue, Sep 25, 2012 at 7:49 AM, Michal Privoznik <mprivozn redhat com> wrote:
> On 25.09.2012 10:58, Dmitry Fleytman wrote:
>> This patch fixes incorrect help screen parsing for QEMU 1.0.1 package
>> Version line changed from
>>     QEMU emulator version 1.0 (qemu-kvm-1.0), Copyright (c) 2003-2008 Fabrice Bellard
>> To
>>     QEMU emulator version 1.0,1 (qemu-kvm-1.0.1), Copyright (c) 2003-2008 Fabrice Bellard
>
> This seems like a bug to me. If it is a micro version number, why is it
> delimited with comma instead of dot? If it is not a micro version
> number, can we threat it like it is?
>
> BTW: what distro is this so I can chase this down to see if it's a bug
> or not?
>
> Michal
>
> --

Upstream had a bug where they released with a comma instead of a
period. The unfortunate thing is that the comma is in the wild. They
accepted a patch afterwards to change it back to a period.

That being said, I believe this worked in libvirt master since I
actually tried it both ways when I contacted upstream QEMU about this
several months back. Its possible though that commits since I've tried
it have broken it.


-- 
Doug Goldstein


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]