[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/5] Rename virCommandTranslateStatus to virProcessTranslateStatus



On 09/25/2012 02:28 PM, Daniel P. Berrange wrote:
> From: "Daniel P. Berrange" <berrange redhat com>
> 
> The virCommand prefix was inappropriate because the API
> does not use any virCommandPtr object instance. This
> API closely related to waitpid/exit, so use virProcess
> as the prefix
> 
> Signed-off-by: Daniel P. Berrange <berrange redhat com>
> ---
>  daemon/remote.c          |  2 +-
>  src/libvirt_private.syms |  2 +-
>  src/util/command.c       | 16 ++++++++--------
>  src/util/command.h       |  2 +-
>  4 files changed, 11 insertions(+), 11 deletions(-)

Well, it CAN be used on the status argument returned by virCommandRun,
but that's a stretch.  I like you rename.

ACK.

> +++ b/src/libvirt_private.syms
> @@ -162,7 +162,7 @@ virCommandSetPreExecHook;
>  virCommandSetWorkingDirectory;
>  virCommandToString;
>  virCommandTransferFD;
> -virCommandTranslateStatus;
> +virProcessTranslateStatus;
>  virCommandWait;

Now unsorted, but a later patch moves it anyways, so no need to sort
just to avoid churn.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]