[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Libvirt-announce] Release of libvirt-1.0.4



On 01/04/2013, at 6:42 PM, Ruben Kerkhof wrote:
<snip>
> Hey Justin, 
> 
> Just tried that, but it has no effect, probably due to:
> 
> if test $with_osx = yes; then
>    with_qemu=no
> fi
> 
> in configure.ac
> 
> I tried to build the latest libvirt HEAD from source, but I'm bumping into an (unrelated) failure:
> 
> Making all in src
>   GEN      lxc/lxc_monitor_dispatch.h
>   GEN      lxc/lxc_controller_dispatch.h
>   GEN      remote/remote_protocol.h
>     unsigned hyper cpu_time;
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^
> remote/remote_protocol.x, line 338: expected ';'
> cannot shutdown /usr/bin/rpcgen:  at ./rpc/genprotocol.pl line 124.
> make[2]: *** [remote/remote_protocol.h] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2

Ouch.  It looks like something is causing the LXC building code to
be run, even on OSX where there's no chance it would work. :(

For good measure, I just tried it with the 1.0.4 tarball and had
the same problem (when enabling qemu after modifying configure).

Someone (not me) would have to investigate why the LXC stuff is
trying to compile.  It's probably just something in the configure.ac
or maybe some ifdef statements needed in the right places in the
code. (no idea)

Don't suppose that's your kind of thing? :)

+ Justin

--
Open Source and Standards @ Red Hat

twitter.com/realjustinclift



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]