[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/7] qemu: QEMU_PCI constant consistency



On 04/04/2013 11:25 AM, Laine Stump wrote:
> On 04/03/2013 11:50 AM, Ján Tomko wrote:
>> Change QEMU_PCI_ADDRESS_LAST_SLOT to the number of slots in the bus,
>> not the maximum slot value, to match QEMU_PCI_ADDRESS_LAST_FUNCTION.
>> ---
> 
> If you want to be *really* consistent, you should rename these to
> VIR_QEMU_PCI_ADDRESS_SLOT_LAST and VIR_QEMU_PCI_ADDRESS_FUNCTION_LAST :-)
> 
> (i.e. start with "VIR_" and put "LAST" at the end)

A VIR_ prefix might not be necessary, since this define is local to a
qemu_ file; but yes, the bit about _LAST being a suffix in our various
enum tail markers is a valid point.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]