[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 06/18] Rename virCgroupMounted to virCgroupHasController & make it more robust



On 04/04/2013 03:40 PM, Daniel P. Berrange wrote:
> From: "Daniel P. Berrange" <berrange redhat com>
> 
> The virCgroupMounted method is badly named, since a controller can be
> mounted, but disabled in the current object. Rename the method to be
> virCgroupHasController. Also make it tolerant to a  NULL virCgroupPtr
> and out-of-range controller index, to avoid duplication of these
> checks in all callers
> 
> Signed-off-by: Daniel P. Berrange <berrange redhat com>
> ---
>  src/libvirt_private.syms |  2 +-
>  src/lxc/lxc_driver.c     | 12 +-----------
>  src/lxc/lxc_process.c    | 10 +++++-----
>  src/qemu/qemu_cgroup.c   | 14 +-------------
>  src/util/vircgroup.c     | 13 +++++++++----
>  src/util/vircgroup.h     |  2 +-
>  6 files changed, 18 insertions(+), 35 deletions(-)
> 

ACK

Jan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]