[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] rng: tighten up domain <controller> schema

On 18/04/13 17:00, Martin Kletzander wrote:
On 04/18/2013 10:54 AM, Osier Yang wrote:
On 18/04/13 16:42, Martin Kletzander wrote:
On 04/18/2013 06:36 AM, Laine Stump wrote:
The rng schema for <controller> had been non-specific about which
types of controllers allowed which models, and also allowed the
num_queues attribute (since that hasn't been released yet, should we
rename it to "numQueues"?)
Since there's still time (the commit with that is v1.0.4-65-gd4bf0a9), I
think we should rename it ASAP since we are using camelCase for all the
attribute names.

Apart from that, the RNG with this patch is precise according to the
documentation, so ACK.  I'll try to send the numQueues patch to see what
others think.
I guess you mean multiple queues support for virtio network?
Regardless of which style we will use finally, FYI,  "num_queues" is
used for disk.. Personally I'm fine with either, because we already
use both across.

Yes, I meant the virtio-scsi num_queues.  As we're trying not to use
underscores in XML, I hope we can still switch it.  I haven't found any
other num_queues anywhere in the code.  Could you point me to the commit
that uses that?  I'm sending the previously discussed patch in the meantime.

Except the virtio-scsi num_queues, there is no other tag for multiple
queue yet, we will need a patch to support multiple queue for the network,
but it's not committed yet.

It's fine to convert it now, 1.0.5 is not released yet. But is it deserved to
do, we already have many tags with underscore, which can't be changed
for back-compat.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]