[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [libvirt-designer 3/3] Set min versions from configure in .spec file



Minimum libvirt-gobject, libvirt-gconfig and libosinfo versions
are set in configure.ac, it's better not to duplicate them in
libvirt-designer.spec.in, it's too easy to get them out of sync.
---
 configure.ac             | 2 +-
 libvirt-designer.spec.in | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/configure.ac b/configure.ac
index 7167cd1..ebb29e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,9 +15,9 @@ LIBVIRT_GCONFIG_REQUIRED=0.1.7
 LIBVIRT_GOBJECT_REQUIRED=0.1.3
 GOBJECT_INTROSPECTION_REQUIRED=0.10.8
 
-# for proper substitution in README.in
 AC_SUBST(LIBOSINFO_REQUIRED)
 AC_SUBST(LIBVIRT_GCONFIG_REQUIRED)
+AC_SUBST(LIBVIRT_GOBJECT_REQUIRED)
 
 LIBVIRT_DESIGNER_MAJOR_VERSION=`echo $VERSION | awk -F. '{print $1}'`
 LIBVIRT_DESIGNER_MINOR_VERSION=`echo $VERSION | awk -F. '{print $2}'`
diff --git a/libvirt-designer.spec.in b/libvirt-designer.spec.in
index d8145b4..894bcb8 100644
--- a/libvirt-designer.spec.in
+++ b/libvirt-designer.spec.in
@@ -20,12 +20,12 @@ License: LGPLv2+
 URL: http://libvirt.org/
 Source0: http://libvirt.org/sources/designer/%{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: libvirt-gconfig-devel >= 0.0.9
-BuildRequires: libvirt-gobject-devel >= 0.1.3
+BuildRequires: libvirt-gconfig-devel >= @LIBVIRT_GCONFIG_REQUIRED@
+BuildRequires: libvirt-gobject-devel >= @LIBVIRT_GOBJECT_REQUIRED@
 %if %{with_introspection}
 BuildRequires: gobject-introspection-devel
 %endif
-BuildRequires: libosinfo-devel >= 0.0.5
+BuildRequires: libosinfo-devel >= @LIBOSINFO_REQUIRED@
 
 %package libs
 Group: Development/Libraries
@@ -35,7 +35,7 @@ Summary: Libvirt configuration designer libraries
 Group: Development/Libraries
 Summary: Libvirt configuration designer development headers
 Requires: %{name}-libs = %{version}-%{release}
-Requires: libvirt-gconfig-devel >= 0.0.9
+Requires: libvirt-gconfig-devel >= @LIBVIRT_GCONFIG_REQUIRED@
 
 %description
 This package provides the libvirt configuration designer command
-- 
1.8.1.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]