[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Use camelCase for XML attribute numQueues



On 04/22/2013 04:43 PM, Laine Stump wrote:
> On 04/22/2013 10:13 AM, Laine Stump wrote:
>> Of course in this case, we *could* avoid the camelCase vs underscore
>> entirely by just naming the attribute "queues" instead of numQueues or
>> num_queues (the fact that the attribute is a number makes it pretty
>> obvious that it is the "number of queues").
> 
> And I notice that the patches for supporting multiple queues in
> interfaces uses <driver queues='n'/>, so consistency would vote in favor
> of using the same thing for <controller>.
> 

I'm not the '+1' kind of guy, but this makes way more sense in the
driver element and I think we would definitely make a use of that in the
future, even though it increases the complexity of XML.  Since there's
still time, should I try to change it to <driver queues... or is
somebody else against (or already did) that?  (Last time I wrongly
assumed that sending the patch would speed up solving the question, so
I'm rather asking now).

Martin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]