[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] qemu: assume virtio-memballon without an address to be PCI



On Fri, Apr 26, 2013 at 01:51:51PM +0200, Ján Tomko wrote:
> When doing XML-to-native conversion, addresses are not assigned.
> The code building memballon device string assumed they are and
> returned an error without reporting any error message, leading to:
>     error: An error occurred, but the cause is unknown
> 
> Assume that address type none means it's a PCI device, as we do
> for other virtio devices.
> 
> Fixes https://bugzilla.redhat.com/show_bug.cgi?id=957077
> ---
> 
> This still leaves XML-to-native conversion broken for S390
> machines, not just for memballon, but for other virtio devices
> as well. Should we assign addresses in DomainXMLToNative as well,
> or just decide which virtio device to add based on the machine type?

The XML-to-native API is intended to generate the same command
line that libvirt would use, except without any FD passing. If
we're to keep that equivalance, then we should be assigning
adresses when running DomainXMLToNative too.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]