[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/7] qemu: rename some functions in qemu_command.c

On 08/02/2013 10:55 AM, Laine Stump wrote:
> * qemuDomainPCIAddressSetNextAddr
> The name of this function was confusing because 1) other functions in
> the file that end in "Addr" are only operating on a single function of
> one PCI slot, not the entire slot, while functions that do something
> with the entire slot end in "Slot", and 2) it didn't contain a verb
> describing what it is doing (the "Set" refers to the set that contains
> all PCI buses in the system, used to keep track of which slots in
> which buses are already reserved for use).
> It is now renamed to qemuDomainPCIAddressReserveNextSlot, which more
> clearly describes what it is doing. Arguably, it could have been
> changed to qemuDomainPCIAddressSetReserveNextSlot, but 1) the word
> "set" is confusing in this context because it could be intended as a
> verb or as a noun, and 2) most other functions that operate on a
> single slot or address within this set are also named
> qemuDomainPCIAddress... rather than qemuDomainPCIAddressSet... Only
> the Create, Free, and Grow functions for an address set (which modify the
> entire set, not just one element) use "Set" in their name.
> * qemuPCIAddressAsString, qemuPCIAddressValidate
> All the other functions in this set are named
> qemuDomainPCIAddressxxxxx, so I renamed these to be consistent.
> ---
>  src/qemu/qemu_command.c | 78 ++++++++++++++++++++++++++++++-------------------
>  src/qemu/qemu_command.h |  6 ++--
>  2 files changed, 51 insertions(+), 33 deletions(-)

Not a 1:1 line mapping; but I checked that it's all because of line
re-wrapping now that the names are longer.


Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]