[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-users] Please remove pm-utils dep from libvirt-clients



On Sat, Aug 03, 2013 at 03:41:35PM +0100, Richard Hughes wrote:
> Hi,
> 
> I'm going to be retiring pm-utils from Fedora soon; it's completely
> dead upstream and it not needed anymore by upower or anything else.
> Nothing other than libvirt-clients depends on it, so when I tried to
> remove this from rawhide I noticed this commit:
> 
> commit 7069f75cb8dad58715f723fd542e4ff69dbff51b
> Author: Daniel Veillard <veillard redhat com>
> Date:   Thu Dec 8 17:03:16 2011 +0800
> 
>     update to libvirt-0.9.8
> 
> added:
> 
> +# Needed for probing the power management features of the host.
> +Requires: pm-utils
> 
> Is this true? You really don't want to be parsing pm-is-supported, it
> often doesn't work and isn't used by anything else any more. Would it
> be possible to port away from pm-is-supported if you're actually using
> it, and drop the dep for F20 please? Any questions please CC me as I'm
> not subscribed.

What is the replacement ?  We need to be able to query whether
each of suspend, hibernate, or suspend-hybrid are supported on
a host, and then report that upto the mgmt app using libvirt.


Daniel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]