[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] virDomainCreateWithFlags error



On 08/08/2013 01:54 PM, Wangpan wrote:
Hi all,
I'm using 'libvirt  1.1.1-1  amd64' undef debian wheezy, I found that the return code is 139 when I run command:
$ sudo virsh start df1c4670-18eb-4520-b5d8-aa8a492eb876 --paused; echo $?

Thanks for reporting this issue, it's a libvirt's bug and we can reproduce your
question on libvirt-1.1.1-2.el7.x86_64.


139
but the return code is OK(0) when run command:
$ sudo virsh start df1c4670-18eb-4520-b5d8-aa8a492eb876; echo $?

I found there is an error in libvirtd.log:
2013-08-08 05:40:23.983+0000: 16626: error : virNetSocketReadWire:1377 : End of file while reading data: Input/output error

I found this issue by using openstack nova folsom, if I create an VM by nova, it will use dom.createWithFlags(0) to create the VM, but then the nova-compute process exited when this function is called, then I changed the createWithFlags(0) to create(), everything become OK.
I also tried the function under python, and the python process exited, too. but the dom.create() method is OK, so I think this is a problem about libvirt.
I want to know is this a reported bug?

libvirt and kvm hypervisor version:
Compiled against library: libvirt 1.1.1
Using library: libvirt 1.1.1
Using API: QEMU 1.1.1
Running hypervisor: QEMU 1.1.2

Thanks
2012-08-16
Wangpan

--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]